Adding Items to the Visual Studio Toolbox


As most of you already know, I am currently running the Visual Studio 2008 beta. I know it says it is a release product, but occasionally I find that that expectation is unrealistic, so I will call it beta and be content. 🙂

My current issue is with toolbox. I cannot add custom items to the toolbox. I have cleared temporary files, used devenv /setup and devenv /resetskippkgs and even reset the toolbox. This shows my desperation? Still the IDE crashes.

Finally, after dinking around a bit, an inspiration came to me. Something is loading in the toolbox that is messing things up. If this is true, then the proper way to clear things out, when reset does not work is to use safe mode. So, here is what I have done to solve this problem.

  1. Open a Visual Studio command prompt
  2. Type in devenv /safemode
  3. Right click on the toolbox and choose the option Choose Items
  4. Click each tab. Somewhere in the process, you will notice an exception loading one of the controls
  5. Restart Visual Studio normally
  6. Add controls

Suddenly, I am in coding "heaven" again. Until next time …

Peace and Grace,
Greg

Advertisements

5 Responses to Adding Items to the Visual Studio Toolbox

  1. Unknown says:

    Thankyou!Applies to the release version of VS2008 as well (even SP1), and I think the following item on Microsoft Connect is related:http://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=345965I will copy the link to this blog entry onto that item (hope that is OK) so that anyone lese suffering can find the solution.RegardsJohn

  2. Michael says:

    I have the same issue, however VS 2008 crashes in /safemode when trying to initilize the toolbox…. There is no way to right-click the toolbox without VS starting to initilize and crash.

  3. Frank says:

    Solved my problems too, Thx

  4. Daniel says:

    Tried that but it still crashes at 6.

  5. Kevin says:

    Greg, It is two years later… and I am having the same problem as you describe. However, like Michael Frimu commented here, I am NOT able to proceed with step 4 becase when I right-click on the toolbox VS crashes. This thread seemed to end without resolution for this flavor of the issue. Do you know of a resolution for not getting past step 3 in safemode? I found this forum by chance and do not use it regularly so if you could email the answer to me when you post it back here I would appreciate it. My email is kevin.evers@everrec.com.Thank you.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: